Widomaker and Internet related news or information

D-Link Router Security Issue

Vulnerabilities have recently been discovered that affect certain models of D-Link broadband routers. If you are using one of the affected models you should take steps to update the firmware of your router with the security patch provided by D-Link, or replace the device.

The list of affected D-Link router models can be found in CERT Vulnerability Note VU#248083 or in D-Link’s page on the issue. D-Link’s page says that firmware updates should be available by the 31st of October, 2013.

An example photo of a D-Link DI-524 wireless router (one of the affected models) can be found here.

If your D-Link model IS NOT listed as affected then you DO NOT need to take any action.

You should not continue to operate a vulnerable D-Link router because it will put your computers and personal information at risk.

If you would like to replace an affected D-Link device, and you would like to purchase a replacement router from Widomaker, please call, or e-mail, our office to discuss the available options.

Welcome
This site was setup to help communicate with customers on Widomaker services and network outages/upgrades.
Follow Us

Widomaker is a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for sites to earn advertising fees by advertising and linking to amazon.com.